CVE-2015-0243

NameCVE-2015-0243
DescriptionMultiple buffer overflows in contrib/pgcrypto in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 allow remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-152-1, DSA-3155-1
NVD severitymedium

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4sourcesqueeze8.4.22lts1-0+deb6u1DLA-152-1
postgresql-8.4sourcewheezy(not affected)
postgresql-8.4source(unstable)(unfixed)
postgresql-9.1sourcewheezy9.1.15-0+deb7u1DSA-3155-1
postgresql-9.1source(unstable)9.1.11-2
postgresql-9.4source(unstable)9.4.1-1

Notes

[wheezy] - postgresql-8.4 <not-affected> (postgresql-8.4 in wheezy only provides PL/Perl)

Search for package or bug name: Reporting problems