Information on source package postgresql-9.4

Available versions

ReleaseVersion
jessie9.4.18-0+deb8u1
jessie (security)9.4.19-0+deb8u1

Open issues

BugjessieDescription
CVE-2018-1058vulnerable (no DSA)A flaw was found in the way Postgresql allowed a user to modify the ...
CVE-2018-1053vulnerable (no DSA)In postgresql 9.3.x before 9.3.21, 9.4.x before 9.4.16, 9.5.x before ...

Resolved issues

BugDescription
CVE-2018-16850postgresql before versions 11.1, 10.6 is vulnerable to a to SQL ...
CVE-2018-1115postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack ...
CVE-2018-10925It was discovered that PostgreSQL versions before 10.5, 9.6.10, ...
CVE-2018-10915A vulnerability was found in libpq, the default PostgreSQL client ...
CVE-2018-1052Memory disclosure vulnerability in table partitioning was found in ...
CVE-2017-7548PostgreSQL versions before 9.4.13, 9.5.8 and 9.6.4 are vulnerable to ...
CVE-2017-7547PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are ...
CVE-2017-7546PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are ...
CVE-2017-7486PostgreSQL versions 8.4 - 9.6 are vulnerable to information leak in ...
CVE-2017-7485In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before ...
CVE-2017-7484It was found that some selectivity estimation functions in PostgreSQL ...
CVE-2017-15099INSERT ... ON CONFLICT DO UPDATE commands in PostgreSQL 10.x before ...
CVE-2017-15098Invalid json_populate_recordset or jsonb_populate_recordset function ...
CVE-2017-12172PostgreSQL 10.x before 10.1, 9.6.x before 9.6.6, 9.5.x before 9.5.10, ...
CVE-2016-5424PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, ...
CVE-2016-5423PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, ...
CVE-2016-3065The (1) brin_page_type and (2) brin_metapage_info functions in the ...
CVE-2016-2193PostgreSQL before 9.5.x before 9.5.2 does not properly maintain ...
CVE-2016-0773PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, ...
CVE-2016-0766PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, ...
CVE-2015-5289Multiple stack-based buffer overflows in json parsing in PostgreSQL ...
CVE-2015-5288The crypt function in contrib/pgcrypto in PostgreSQL before 9.0.23, ...
CVE-2015-3167
CVE-2015-3166
CVE-2015-3165Double free vulnerability in PostgreSQL before 9.0.20, 9.1.x before ...
CVE-2015-0244
CVE-2015-0243
CVE-2015-0242
CVE-2015-0241
CVE-2014-8161

Security announcements

DSA / DLADescription
DLA-1464-1postgresql-9.4 - security update
DSA-4027-1postgresql-9.4 - security update
DSA-3935-1postgresql-9.4 - security update
DSA-3851-1postgresql-9.4 - security update
DSA-3646-1postgresql-9.4 - security update
DSA-3476-1postgresql-9.4 - security update
DSA-3374-1postgresql-9.4 - security update
DSA-3270-1postgresql-9.4 - security update

Search for package or bug name: Reporting problems