CVE-2015-5199

NameCVE-2015-5199
DescriptionDirectory traversal vulnerability in dlopen in libvdpau before 1.1.1 allows local users to gain privileges via the VDPAU_DRIVER environment variable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-306-1, DSA-3355-1
NVD severityhigh
Debian Bugs797895

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvdpau (PTS)jessie (security), jessie0.8-3+deb8u2fixed
stretch1.1.1-6fixed
buster1.1.1-10fixed
bullseye, sid1.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvdpausource(unstable)1.1.1-1797895
libvdpausourcejessie0.8-3+deb8u1DSA-3355-1
libvdpausourcesqueeze0.4.1-2+deb6u1DLA-306-1
libvdpausourcewheezy0.4.1-7+deb7u1DSA-3355-1

Notes

http://lists.x.org/archives/xorg-announce/2015-August/002630.html
http://cgit.freedesktop.org/~aplattner/libvdpau/commit/?id=d1f9c16b1a8187110e501c9116d21ffee25c0ba4

Search for package or bug name: Reporting problems