CVE-2015-5288

NameCVE-2015-5288
DescriptionThe crypt function in contrib/pgcrypto in PostgreSQL before 9.0.23, 9.1.x before 9.1.19, 9.2.x before 9.2.14, 9.3.x before 9.3.10, and 9.4.x before 9.4.5 allows attackers to cause a denial of service (server crash) or read arbitrary server memory via a "too-short" salt.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-329-1, DSA-3374-1, DSA-3475-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-8.4 (PTS)wheezy8.4.22-0+deb7u1fixed
postgresql-9.1 (PTS)wheezy9.1.21-0+deb7u1fixed
wheezy (security)9.1.24lts2-0+deb7u1fixed
jessie9.1.22-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed
postgresql-9.4 (PTS)jessie9.4.12-0+deb8u1fixed
jessie (security)9.4.13-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4source(unstable)(unfixed)medium
postgresql-8.4sourcesqueeze8.4.22lts5-0+deb6u1mediumDLA-329-1
postgresql-8.4sourcewheezy(not affected)
postgresql-9.1source(unstable)(unfixed)medium
postgresql-9.1sourcejessie(not affected)
postgresql-9.1sourcewheezy9.1.20-0+deb7u1mediumDSA-3475-1
postgresql-9.4source(unstable)9.4.5-1medium
postgresql-9.4sourcejessie9.4.5-0+deb8u1mediumDSA-3374-1

Notes

[jessie] - postgresql-9.1 <not-affected> (postgresql-9.1 in jessie only provides PL/Perl)
[wheezy] - postgresql-8.4 <not-affected> (postgresql-8.4 in wheezy only provides PL/Perl; EOL upstream)
[squeeze] - postgresql-8.4 <no-dsa> (minor issue)

Search for package or bug name: Reporting problems