CVE-2015-5289

NameCVE-2015-5289
DescriptionMultiple stack-based buffer overflows in json parsing in PostgreSQL before 9.3.x before 9.3.10 and 9.4.x before 9.4.5 allow attackers to cause a denial of service (server crash) via unspecified vectors, which are not properly handled in (1) json or (2) jsonb values.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3374-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-8.4 (PTS)wheezy8.4.22-0+deb7u1fixed
postgresql-9.1 (PTS)wheezy9.1.21-0+deb7u1fixed
wheezy (security)9.1.24lts2-0+deb7u1fixed
jessie9.1.22-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed
postgresql-9.4 (PTS)jessie (security), jessie9.4.15-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4source(unstable)(not affected)
postgresql-9.1source(unstable)(not affected)
postgresql-9.4source(unstable)9.4.5-1medium
postgresql-9.4sourcejessie9.4.5-0+deb8u1mediumDSA-3374-1

Notes

- postgresql-9.1 <not-affected> (no json datatype)
- postgresql-8.4 <not-affected> (no json datatype)

Search for package or bug name: Reporting problems