CVE-2015-5723

NameCVE-2015-5723
DescriptionDoctrine Annotations before 1.2.7, Cache before 1.3.2 and 1.4.x before 1.4.2, Common before 2.4.3 and 2.5.x before 2.5.1, ORM before 2.4.8 or 2.5.x before 2.5.1, MongoDB ODM before 1.0.2, and MongoDB ODM Bundle before 3.0.1 use world-writable permissions for cache directories, which allows local users to execute arbitrary PHP code with additional privileges by leveraging an application with the umask set to 0 and that executes cache entries as code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3369-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
aws-sdk-for-php (PTS)jessie2.7.2-1fixed
doctrine (PTS)wheezy1.2.4-1vulnerable
jessie2.4.6-1+deb8u1fixed
stretch2.5.4+dfsg-2fixed
buster, sid2.5.13+dfsg-1fixed
php-doctrine-annotations (PTS)jessie1.2.1-1+deb8u1fixed
stretch1.2.7-2fixed
buster, sid1.5.0really1.2.7-1fixed
php-doctrine-bundle (PTS)stretch1.6.7-1fixed
buster, sid1.8.1-1fixed
php-doctrine-cache (PTS)jessie1.3.1-1+deb8u1fixed
stretch1.6.1-1fixed
buster, sid1.7.0really1.6.1-1fixed
php-doctrine-common (PTS)jessie2.4.2-2+deb8u1fixed
buster, sid, stretch2.6.1-2fixed
zendframework (PTS)wheezy1.11.13-1.1+deb7u6fixed
wheezy (security)1.11.13-1.1+deb7u5fixed
jessie1.12.9+dfsg-2+deb8u6fixed
jessie (security)1.12.9+dfsg-2+deb8u4fixed
sid1.12.20+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aws-sdk-for-phpsource(unstable)(not affected)
aws-sdk-for-phpsourceexperimental3.2.1-1high
doctrinesource(unstable)2.4.8-1low
doctrinesourceexperimental2.5.1+dfsg-1high
doctrinesourcejessie2.4.6-1+deb8u1high
php-doctrine-annotationssource(unstable)1.2.7-1low
php-doctrine-annotationssourcejessie1.2.1-1+deb8u1high
php-doctrine-bundlesource(unstable)1.5.2-1low
php-doctrine-cachesource(unstable)1.4.2-1low
php-doctrine-cachesourcejessie1.3.1-1+deb8u1high
php-doctrine-commonsource(unstable)2.4.3-1low
php-doctrine-commonsourceexperimental2.5.1-1high
php-doctrine-commonsourcejessie2.4.2-2+deb8u1high
zendframeworksource(unstable)1.12.16+dfsg-1low
zendframeworksourcejessie1.12.9+dfsg-2+deb8u4highDSA-3369-1
zendframeworksourcesqueeze(not affected)
zendframeworksourcewheezy1.11.13-1.1+deb7u4highDSA-3369-1

Notes

[wheezy] - doctrine <no-dsa> (Minor issue)
[squeeze] - doctrine <no-dsa> (Minor issue)
- aws-sdk-for-php <not-affected> (Vulnerable code not present)
[squeeze] - zendframework <not-affected> (No unsafe permissions found in cache functions)
Review of zendframework 1.10.6 in Squeeze found no usage of default unsafe permission except in library/Zend/Search/Lucene/Storage/Directory/Filesystem.php but which is unlikely to cause a security issue.
http://www.doctrine-project.org/2015/08/31/security_misconfiguration_vulnerability_in_various_doctrine_projects.html
https://github.com/aws/aws-sdk-php/releases/tag/3.2.1
http://framework.zend.com/security/advisory/ZF2015-07

Search for package or bug name: Reporting problems