CVE-2015-8327

NameCVE-2015-8327
DescriptionIncomplete blacklist vulnerability in util.c in foomatic-rip in cups-filters 1.0.42 before 1.2.0 and in foomatic-filters in Foomatic 4.0.x allows remote attackers to execute arbitrary commands via ` (backtick) characters in a print job.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-365-1, DSA-3411-1, DSA-3429-1
NVD severityhigh
Debian Bugs806886

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups-filters (PTS)jessie1.0.61-5+deb8u3fixed
jessie (security)1.0.61-5+deb8u4fixed
stretch (security), stretch1.11.6-3+deb9u1fixed
buster1.21.6-5fixed
bullseye1.27.1-1fixed
sid1.27.1-3fixed
foomatic-filters (PTS)jessie (security), jessie4.0.17-5+deb8u1fixed
stretch4.0.17-9fixed
bullseye, sid, buster4.0.17-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cups-filterssource(unstable)1.2.0-1
cups-filterssourcejessie1.0.61-5+deb8u2DSA-3411-1
cups-filterssourcewheezy(not affected)
foomatic-filterssource(unstable)4.0.17-7806886
foomatic-filterssourcejessie4.0.17-5+deb8u1DSA-3429-1
foomatic-filterssourcesqueeze4.0.5-6+squeeze2+deb6u11DLA-365-1
foomatic-filterssourcewheezy4.0.17-1+deb7u1DSA-3429-1

Notes

[wheezy] - cups-filters <not-affected> (Vulnerable code not present; introduced in 1.0.42)

Search for package or bug name: Reporting problems