CVE-2015-8560

NameCVE-2015-8560
DescriptionIncomplete blacklist vulnerability in util.c in foomatic-rip in cups-filters 1.0.42 before 1.4.0 and in foomatic-filters in Foomatic 4.0.x allows remote attackers to execute arbitrary commands via a ; (semicolon) character in a print job, a different vulnerability than CVE-2015-8327.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-371-1, DSA-3419-1, DSA-3429-1
NVD severityhigh (attack range: remote)
Debian Bugs807930, 807993

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups-filters (PTS)wheezy, wheezy (security)1.0.18-2.1+deb7u2fixed
jessie (security), jessie1.0.61-5+deb8u3fixed
stretch1.11.6-3fixed
buster, sid1.17.9-1fixed
foomatic-filters (PTS)wheezy, wheezy (security)4.0.17-1+deb7u1fixed
jessie (security), jessie4.0.17-5+deb8u1fixed
stretch4.0.17-9fixed
buster, sid4.0.17-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cups-filterssource(unstable)1.4.0-1high807930
cups-filterssourcejessie1.0.61-5+deb8u3highDSA-3419-1
cups-filterssourcewheezy(not affected)
foomatic-filterssource(unstable)4.0.17-7high807993
foomatic-filterssourcejessie4.0.17-5+deb8u1highDSA-3429-1
foomatic-filterssourcesqueeze4.0.5-6+squeeze2+deb6u12highDLA-371-1
foomatic-filterssourcewheezy4.0.17-1+deb7u1highDSA-3429-1

Notes

[wheezy] - cups-filters <not-affected> (Vulnerable code not present; introduced in 1.0.42)
http://bzr.linuxfoundation.org/loggerhead/openprinting/cups-filters/revision/7419
http://www.openwall.com/lists/oss-security/2015/12/13/2

Search for package or bug name: Reporting problems