CVE-2016-1238

NameCVE-2016-1238
Description(1) cpan/Archive-Tar/bin/ptar, (2) cpan/Archive-Tar/bin/ptardiff, (3) cpan/Archive-Tar/bin/ptargrep, (4) cpan/CPAN/scripts/cpan, (5) cpan/Digest-SHA/shasum, (6) cpan/Encode/bin/enc2xs, (7) cpan/Encode/bin/encguess, (8) cpan/Encode/bin/piconv, (9) cpan/Encode/bin/ucmlint, (10) cpan/Encode/bin/unidump, (11) cpan/ExtUtils-MakeMaker/bin/instmodsh, (12) cpan/IO-Compress/bin/zipdetails, (13) cpan/JSON-PP/bin/json_pp, (14) cpan/Test-Harness/bin/prove, (15) dist/ExtUtils-ParseXS/lib/ExtUtils/xsubpp, (16) dist/Module-CoreList/corelist, (17) ext/Pod-Html/bin/pod2html, (18) utils/c2ph.PL, (19) utils/h2ph.PL, (20) utils/h2xs.PL, (21) utils/libnetcfg.PL, (22) utils/perlbug.PL, (23) utils/perldoc.PL, (24) utils/perlivp.PL, and (25) utils/splain.PL in Perl 5.x before 5.22.3-RC2 and 5.24 before 5.24.1-RC2 do not properly remove . (period) characters from the end of the includes directory array, which might allow local users to gain privileges via a Trojan horse module under the current working directory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-565-1, DLA-584-1, DSA-3628-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsys-syslog-perl (PTS)wheezy0.29-1vulnerable
wheezy (security)0.29-1+deb7u1fixed
jessie (security), jessie0.33-1+deb8u1fixed
perl (PTS)wheezy5.14.2-21+deb7u3vulnerable
wheezy (security)5.14.2-21+deb7u5fixed
jessie5.20.2-3+deb8u8fixed
jessie (security)5.20.2-3+deb8u7fixed
stretch5.24.1-3+deb9u1fixed
buster, sid5.26.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsys-syslog-perlsource(unstable)(unfixed)high
libsys-syslog-perlsourcejessie0.33-1+deb8u1high
libsys-syslog-perlsourcewheezy0.29-1+deb7u1highDLA-584-1
perlsource(unstable)5.22.2-3high
perlsourcejessie5.20.2-3+deb8u6highDSA-3628-1
perlsourcewheezy5.14.2-21+deb7u4highDLA-565-1

Notes

http://article.gmane.org/gmane.comp.lang.perl.perl5.porters/160507
Although more modules and scripts are affected by similar issue and mentioned
in the DSA/DLA, the CVE is for src:perl (and libsys-syslog-perl beeing dual-lived)
and thus not adding more source packages here.

Search for package or bug name: Reporting problems