CVE-2016-2098

NameCVE-2016-2098
DescriptionAction Pack in Ruby on Rails before 3.2.22.2, 4.x before 4.1.14.2, and 4.2.x before 4.2.5.2 allows remote attackers to execute arbitrary Ruby code by leveraging an application's unrestricted use of the render method.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-604-1, DSA-3509-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)wheezy2:2.3.14.2fixed
jessie (security), jessie2:4.1.8-1+deb8u4fixed
stretch2:4.2.7.1-1fixed
buster, sid2:4.2.9-4fixed
ruby-actionpack-2.3 (PTS)wheezy2.3.14-5vulnerable
ruby-actionpack-3.2 (PTS)wheezy3.2.6-6+deb7u2vulnerable
wheezy (security)3.2.6-6+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2:4.2.5.2-1high
railssourcejessie2:4.1.8-1+deb8u2highDSA-3509-1
railssourcesqueeze(unfixed)end-of-life
railssourcewheezy(not affected)
ruby-actionpack-2.3source(unstable)(unfixed)high
ruby-actionpack-2.3sourcewheezy(unfixed)end-of-life
ruby-actionpack-3.2source(unstable)(unfixed)high
ruby-actionpack-3.2sourcewheezy3.2.6-6+deb7u3highDLA-604-1

Notes

[wheezy] - rails <not-affected> (Vulnerable code not present, is only a transitional package)
[squeeze] - rails <end-of-life> (Not supported in Squeeze LTS)
Versions Affected: 3.2.x, 4.0.x, 4.1.x, 4.2.x
Fixed Versions: 3.2.22.2, 4.1.14.2, 4.2.5.2

Search for package or bug name: Reporting problems