CVE-2016-2193

NameCVE-2016-2193
DescriptionPostgreSQL before 9.5.x before 9.5.2 does not properly maintain row-security status in cached plans, which might allow attackers to bypass intended access restrictions by leveraging a session that performs queries as more than one role.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-9.1 (PTS)jessie9.1.22-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed
postgresql-9.4 (PTS)jessie9.4.18-0+deb8u1fixed
jessie (security)9.4.24-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4source(unstable)(not affected)
postgresql-9.1source(unstable)(not affected)
postgresql-9.4source(unstable)(not affected)
postgresql-9.5source(unstable)9.5.2-1medium

Notes

- postgresql-9.4 <not-affected> (Only affects 9.5.x)
- postgresql-9.1 <not-affected> (Only affects 9.5.x)
- postgresql-8.4 <not-affected> (Only affects 9.5.x)
http://www.postgresql.org/about/news/1656/
http://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=db69e58a0642ef7fa46d62f6c4cf2460c3a1b41b

Search for package or bug name: Reporting problems