DescriptionPostgreSQL before 9.5.x before 9.5.2 does not properly maintain row-security status in cached plans, which might allow attackers to bypass intended access restrictions by leveraging a session that performs queries as more than one role.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4source(unstable)(not affected)
postgresql-9.1source(unstable)(not affected)
postgresql-9.4source(unstable)(not affected)


- postgresql-9.4 <not-affected> (Only affects 9.5.x)
- postgresql-9.1 <not-affected> (Only affects 9.5.x)
- postgresql-8.4 <not-affected> (Only affects 9.5.x);a=commitdiff;h=db69e58a0642ef7fa46d62f6c4cf2460c3a1b41b

Search for package or bug name: Reporting problems