CVE-2016-3717

NameCVE-2016-3717
DescriptionThe LABEL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote attackers to read arbitrary files via a crafted image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1401-1, DLA-484-1, DLA-486-1, DSA-3580-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)stretch (security), stretch1.3.30+hg15796-1~deb9u4fixed
buster, buster (security)1.4+really1.3.35-1~deb10u1fixed
bullseye, sid1.4+really1.3.35+hg16297-1fixed
imagemagick (PTS)stretch8:6.9.7.4+dfsg-11+deb9u8fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u10fixed
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bullseye, sid8:6.9.11.24+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksourcewheezy1.3.16-1.1+deb7u1DLA-484-1
graphicsmagicksourcejessie1.3.20-3+deb8u3DLA-1401-1
graphicsmagicksource(unstable)1.3.24-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u5DLA-486-1
imagemagicksourcejessie8:6.8.9.9-5+deb8u2DSA-3580-1
imagemagicksource(unstable)8:6.9.6.2+dfsg-2

Notes

https://sourceforge.net/p/graphicsmagick/mailman/message/35072963/

Search for package or bug name: Reporting problems