CVE-2016-3718

NameCVE-2016-3718
DescriptionThe (1) HTTP and (2) FTP coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allow remote attackers to conduct server-side request forgery (SSRF) attacks via a crafted image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-484-1, DLA-486-1, DSA-3580-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)wheezy1.3.16-1.1vulnerable
wheezy (security)1.3.16-1.1+deb7u9fixed
jessie1.3.20-3+deb8u1vulnerable
jessie (security)1.3.20-3+deb8u2vulnerable
stretch1.3.25-8fixed
buster1.3.26-9fixed
sid1.3.26-10fixed
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u16fixed
jessie8:6.8.9.9-5+deb8u9fixed
jessie (security)8:6.8.9.9-5+deb8u10fixed
stretch8:6.9.7.4+dfsg-11fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u1fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.24-1medium
graphicsmagicksourcewheezy1.3.16-1.1+deb7u1mediumDLA-484-1
imagemagicksource(unstable)8:6.9.6.2+dfsg-2medium
imagemagicksourcejessie8:6.8.9.9-5+deb8u2mediumDSA-3580-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u5mediumDLA-486-1

Notes

https://sourceforge.net/p/graphicsmagick/mailman/message/35072963/

Search for package or bug name: Reporting problems