CVE-2016-4570

NameCVE-2016-4570
DescriptionThe mxmlDelete function in mxml-node.c in mxml 2.9, 2.7, and possibly earlier allows remote attackers to cause a denial of service (stack consumption) via crafted xml file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1641-1
NVD severityhigh (attack range: remote)
Debian Bugs825855

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mxml (PTS)jessie2.6-2vulnerable
jessie (security)2.6-2+deb8u1fixed
stretch2.10-1fixed
buster, sid2.12-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mxmlsource(unstable)2.9-1high825855
mxmlsourcejessie2.6-2+deb8u1highDLA-1641-1

Notes

[wheezy] - mxml <no-dsa> (Minor issue)
http://www.openwall.com/lists/oss-security/2016/05/07/8
https://github.com/michaelrsweet/mxml/commit/d8c0ba900728d47523d76ba4acf33176cd04647c

Search for package or bug name: Reporting problems