CVE-2016-7103

NameCVE-2016-7103
DescriptionCross-site scripting (XSS) vulnerability in jQuery UI before 1.12.0 might allow remote attackers to inject arbitrary web script or HTML via the closeText parameter of the dialog function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2889-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)stretch7.52-2+deb9u11vulnerable
stretch (security)7.52-2+deb9u18fixed
jqueryui (PTS)stretch1.12.1+dfsg-4fixed
buster1.12.1+dfsg-5fixed
bullseye1.12.1+dfsg-8+deb11u1fixed
bookworm, sid1.13.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal7sourcestretch7.52-2+deb9u17DLA-2889-1
drupal7source(unstable)(unfixed)
jqueryuisource(unstable)1.12.1+dfsg-1

Notes

[jessie] - jqueryui <no-dsa> (Minor issue)
[wheezy] - jqueryui <no-dsa> (Minor issue)
https://nodesecurity.io/advisories/127
https://github.com/jquery/jquery-ui/pull/1622
https://github.com/jquery/jquery-ui/pull/1632
https://github.com/jquery/api.jqueryui.com/issues/281
https://www.drupal.org/sa-core-2022-002

Search for package or bug name: Reporting problems