CVE-2016-9808

NameCVE-2016-9808
DescriptionThe FLIC decoder in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (out-of-bounds write and crash) via a crafted series of skip and count pairs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-good1.0 (PTS)buster, buster (security)1.14.4-1+deb10u1fixed
bullseye1.18.4-2fixed
bookworm, sid1.20.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-good0.10sourcewheezy0.10.31-3+nmu1+deb7u1
gst-plugins-good0.10sourcejessie0.10.31-3+nmu4+deb8u2
gst-plugins-good0.10source(unstable)(unfixed)
gst-plugins-good1.0sourcejessie1.4.4-2+deb8u2
gst-plugins-good1.0source(unstable)1.10.1-2

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=774859
https://cgit.freedesktop.org/gstreamer/gst-plugins-good/commit/?id=153a8ae752c90d07190ef45803422a4f71ea8bff
https://scarybeastsecurity.blogspot.dk/2016/11/0day-poc-incorrect-fix-for-gstreamer.html

Search for package or bug name: Reporting problems