CVE-2016-9810

NameCVE-2016-9810
DescriptionThe gst_decode_chain_free_internal function in the flxdex decoder in gst-plugins-good in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (invalid memory read and crash) via an invalid file, which triggers an incorrect unref call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-good1.0 (PTS)bullseye (security), bullseye1.18.4-2+deb11u2fixed
bookworm, bookworm (security)1.22.0-5+deb12u1fixed
sid, trixie1.24.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-good0.10sourcewheezy0.10.31-3+nmu1+deb7u1
gst-plugins-good0.10sourcejessie0.10.31-3+nmu4+deb8u2
gst-plugins-good0.10source(unstable)(unfixed)
gst-plugins-good1.0sourcejessie1.4.4-2+deb8u2
gst-plugins-good1.0source(unstable)1.10.1-2

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=774897

Search for package or bug name: Reporting problems