CVE-2016-9877

NameCVE-2016-9877
DescriptionAn issue was discovered in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6 and RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12, and 1.7.x before 1.7.7. MQTT (MQ Telemetry Transport) connection authentication with a username/password pair succeeds if an existing username is provided but the password is omitted from the connection request. Connections that use TLS with a client-provided certificate are not affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3761-1
NVD severityhigh (attack range: remote)
Debian Bugs849849

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rabbitmq-server (PTS)wheezy2.8.4-1fixed
jessie (security), jessie3.3.5-1.1+deb8u1fixed
stretch3.6.6-1fixed
buster, sid3.6.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rabbitmq-serversource(unstable)3.6.6-1high849849
rabbitmq-serversourcejessie3.3.5-1.1+deb8u1highDSA-3761-1
rabbitmq-serversourcewheezy(not affected)

Notes

[wheezy] - rabbitmq-server <not-affected> (Vulnerable code introduced later)
https://pivotal.io/security/cve-2016-9877
https://github.com/rabbitmq/rabbitmq-mqtt/issues/96
https://github.com/rabbitmq/rabbitmq-mqtt/pull/98

Search for package or bug name: Reporting problems