CVE-2017-1000158

NameCVE-2017-1000158
DescriptionCPython (aka Python) up to 2.7.13 is vulnerable to an integer overflow in the PyString_DecodeEscape function in stringobject.c, resulting in heap-based buffer overflow (and possible arbitrary code execution)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1189-1, DLA-1190-1, DLA-1519-1, DLA-1520-1, DSA-4307-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python2.7 (PTS)jessie2.7.9-2+deb8u1vulnerable
jessie (security)2.7.9-2+deb8u2fixed
stretch (security), stretch2.7.13-2+deb9u3fixed
buster, sid2.7.15-5fixed
python3.4 (PTS)jessie3.4.2-1vulnerable
jessie (security)3.4.2-1+deb8u1fixed
python3.5 (PTS)stretch (security), stretch3.5.3-1+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.6source(unstable)(unfixed)high
python2.6sourcewheezy2.6.8-1.1+deb7u1highDLA-1190-1
python2.7source(unstable)2.7.13-4high
python2.7sourcejessie2.7.9-2+deb8u2highDLA-1519-1
python2.7sourcestretch2.7.13-2+deb9u2high
python2.7sourcewheezy2.7.3-6+deb7u4highDLA-1189-1
python3.4source(unstable)(unfixed)high
python3.4sourcejessie3.4.2-1+deb8u1highDLA-1520-1
python3.5source(unstable)3.5.5-1high
python3.5sourcestretch3.5.3-1+deb9u1highDSA-4307-1

Notes

https://bugs.python.org/issue30657
2.7 https://github.com/python/cpython/commit/c3c9db89273fabc62ea1b48389d9a3000c1c03ae (v2.7.14rc1)
3.4 https://github.com/python/cpython/commit/6c004b40f9d51872d848981ef1a18bb08c2dfc42 (v3.4.8rc1)
3.5 https://github.com/python/cpython/commit/fd8614c5c5466a14a945db5b059c10c0fb8f76d9 (v3.5.5rc1)
The 2.7.13-4 upload included the commit in debian/patches/git-updates.diff

Search for package or bug name: Reporting problems