CVE-2017-1000487

NameCVE-2017-1000487
DescriptionPlexus-utils before 3.0.16 is vulnerable to command injection because it does not correctly process the contents of double quoted strings.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1236-1, DLA-1237-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
plexus-utils (PTS)wheezy (security)1:1.5.15-4+deb7u1fixed
wheezy, jessie, stretch1:1.5.15-4vulnerable
buster, sid1:1.5.15-5fixed
plexus-utils2 (PTS)wheezy2.0.5-1vulnerable
wheezy (security)2.0.5-1+deb7u1fixed
jessie3.0.15-1vulnerable
stretch3.0.22-1fixed
buster, sid3.0.24-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
plexus-utilssource(unstable)1:1.5.15-5high
plexus-utilssourcewheezy1:1.5.15-4+deb7u1highDLA-1236-1
plexus-utils2source(unstable)3.0.22-1high
plexus-utils2sourcewheezy2.0.5-1+deb7u1highDLA-1237-1

Notes

https://snyk.io/vuln/SNYK-JAVA-ORGCODEHAUSPLEXUS-31522
https://github.com/codehaus-plexus/plexus-utils/commit/b38a1b3a4352303e4312b2bb601a0d7ec6e28f41

Search for package or bug name: Reporting problems