CVE-2017-10379

NameCVE-2017-10379
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Client programs). Supported versions that are affected are 5.5.57 and earlier, 5.6.37 and earlier and 5.7.19 and earlier. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all MySQL Server accessible data. CVSS 3.0 Base Score 6.5 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1141-1, DSA-4002-1
NVD severitymedium (attack range: remote)
Debian Bugs878398, 878402, 884065

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-5.5 (PTS)wheezy5.5.47-0+deb7u1vulnerable
wheezy (security)5.5.59-0+deb7u1fixed
jessie5.5.58-0+deb8u1fixed
jessie (security)5.5.59-0+deb8u1fixed
mysql-5.7 (PTS)sid5.7.21-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.2source(unstable)(unfixed)medium884065
mysql-5.5source(unstable)(unfixed)medium878402
mysql-5.5sourcejessie5.5.58-0+deb8u1mediumDSA-4002-1
mysql-5.5sourcewheezy5.5.58-0+deb7u1mediumDLA-1141-1
mysql-5.7source(unstable)5.7.20-1medium878398

Notes

http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html#AppendixMSQL

Search for package or bug name: Reporting problems