CVE-2017-11142

NameCVE-2017-11142
DescriptionIn PHP before 5.6.31, 7.x before 7.0.17, and 7.1.x before 7.1.3, remote attackers could cause a CPU consumption denial of service attack by injecting long form variables, related to main/php_variables.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1vulnerable
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.25-1fixed
php7.1 (PTS)buster, sid7.1.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)high
php5sourcewheezy(not affected)
php7.0source(unstable)7.0.17-1high
php7.1source(unstable)7.1.3+-1high

Notes

[wheezy] - php5 <not-affected> (vulnerable code not present)
PHP Bug: https://bugs.php.net/bug.php?id=73807
Fixed in 7.1.3, 7.0.17, 5.6.31
https://github.com/php/php-src/commit/a15bffd105ac28fd0dd9b596632dbf035238fda3
https://github.com/php/php-src/commit/0f8cf3b8497dc45c010c44ed9e96518e11e19fc3
http://openwall.com/lists/oss-security/2017/07/10/6

Search for package or bug name: Reporting problems