CVE-2017-11144

NameCVE-2017-11144
DescriptionIn PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, the openssl extension PEM sealing code did not check the return value of the OpenSSL sealing function, which could lead to a crash of the PHP interpreter, related to an interpretation conflict for a negative number in ext/openssl/openssl.c, and an OpenSSL documentation omission.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1034-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1vulnerable
php7.0 (PTS)stretch7.0.19-1vulnerable
buster, sid7.0.22-3fixed
php7.1 (PTS)buster, sid7.1.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)medium
php5sourcewheezy5.4.45-0+deb7u9mediumDLA-1034-1
php7.0source(unstable)7.0.22-1medium
php7.1source(unstable)7.1.8-1medium

Notes

PHP Bug: https://bugs.php.net/bug.php?id=74651
Fixed in 7.1.7, 7.0.21, 5.6.31
http://git.php.net/?p=php-src.git;a=commitdiff;h=89637c6b41b510c20d262c17483f582f115c66d6
http://git.php.net/?p=php-src.git;a=commit;h=73cabfedf519298e1a11192699f44d53c529315e
http://git.php.net/?p=php-src.git;a=commit;h=91826a311dd37f4c4e5d605fa7af331e80ddd4c3
http://openwall.com/lists/oss-security/2017/07/10/6

Search for package or bug name: Reporting problems