CVE-2017-11145

NameCVE-2017-11145
DescriptionIn PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, lack of a bounds check in the date extension's timelib_meridian parsing code could be used by attackers able to supply date strings to leak information from the interpreter, related to an ext/date/lib/parse_date.c out-of-bounds read affecting the php_parse_date function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1034-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u9fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1vulnerable
php7.0 (PTS)stretch7.0.19-1vulnerable
buster, sid7.0.20-2vulnerable
php7.1 (PTS)buster, sid7.1.6-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)medium
php5sourcewheezy5.4.45-0+deb7u9mediumDLA-1034-1
php7.0source(unstable)(unfixed)medium
php7.1source(unstable)(unfixed)medium

Notes

PHP Bug: https://bugs.php.net/bug.php?id=74819
Fixed in 7.1.7, 7.0.21, 5.6.31
https://gist.github.com/anonymous/bd77ac90d3bdf31ce2a5251ad92e9e75
When fixing this CVE make sure to make the fix complete, as per
https://marc.info/?l=oss-security&m=149969403317810&w=2 to not
open CVE-2017-11146. Make sure to apply as well the following
commit:
https://github.com/php/php-src/commit/e8b7698f5ee757ce2c8bd10a192a491a498f891c
http://openwall.com/lists/oss-security/2017/07/10/6

Search for package or bug name: Reporting problems