CVE-2017-11628

NameCVE-2017-11628
DescriptionIn PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, a stack-based buffer overflow in the zend_ini_do_op() function in Zend/zend_ini_parser.c could cause a denial of service or potentially allow executing code. NOTE: this is only relevant for PHP applications that accept untrusted input (instead of the system's php.ini file) for the parse_ini_string or parse_ini_file function, e.g., a web application for syntax validation of php.ini directives.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1066-1, DSA-4080-1, DSA-4081-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1fixed
jessie (security)5.6.37+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch (security), stretch7.0.30-0+deb9u1fixed
buster, sid7.0.31-1fixed
php7.1 (PTS)buster, sid7.1.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)low
php5sourcejessie5.6.33+dfsg-0+deb8u1mediumDSA-4081-1
php5sourcewheezy5.4.45-0+deb7u10mediumDLA-1066-1
php7.0source(unstable)7.0.22-1low
php7.0sourcestretch7.0.27-0+deb9u1mediumDSA-4080-1
php7.1source(unstable)7.1.8-1low

Notes

https://bugs.php.net/bug.php?id=74603
Fixed in 7.1.7, 7.0.21, 5.6.31
Fixed by https://git.php.net/?p=php-src.git;a=commit;h=05255749139b3686c8a6a58ee01131ac0047465e

Search for package or bug name: Reporting problems