CVE-2017-12933

NameCVE-2017-12933
DescriptionThe finish_nested_data function in ext/standard/var_unserializer.re in PHP before 5.6.31, 7.0.x before 7.0.21, and 7.1.x before 7.1.7 is prone to a buffer over-read while unserializing untrusted data. Exploitation of this issue can have an unspecified impact on the integrity of PHP.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1076-1, DSA-4080-1, DSA-4081-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1fixed
jessie (security)5.6.36+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch (security), stretch7.0.30-0+deb9u1fixed
buster, sid7.0.31-1fixed
php7.1 (PTS)buster, sid7.1.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)high
php5sourcejessie5.6.33+dfsg-0+deb8u1highDSA-4081-1
php5sourcewheezy5.4.45-0+deb7u11highDLA-1076-1
php7.0source(unstable)7.0.22-1high
php7.0sourcestretch7.0.27-0+deb9u1highDSA-4080-1
php7.1source(unstable)7.1.8-1high

Notes

Fixed in 7.1.7, 7.0.21, 5.6.31
PHP Bug: https://bugs.php.net/bug.php?id=74111

Search for package or bug name: Reporting problems