CVE-2017-14313

NameCVE-2017-14313
DescriptionThe shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1096-1, DSA-3973-1
NVD severitymedium (attack range: remote)
Debian Bugs874416

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress-shibboleth (PTS)wheezy (security)1.4-2+deb7u1fixed
jessie (security)1.4-2+deb8u1fixed
wheezy, jessie, stretch1.4-2vulnerable
stretch (security)1.4-2+deb9u1fixed
buster, sid1.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpress-shibbolethsource(unstable)1.8-1medium874416
wordpress-shibbolethsourcejessie1.4-2+deb8u1mediumDSA-3973-1
wordpress-shibbolethsourcestretch1.4-2+deb9u1mediumDSA-3973-1
wordpress-shibbolethsourcewheezy1.4-2+deb7u1mediumDLA-1096-1

Notes

https://github.com/michaelryanmcneill/shibboleth/commit/1d65ad6786282d23ba1865f56e2fd19188e7c26a
https://make.wordpress.org/plugins/2015/04/20/fixing-add_query_arg-and-remove_query_arg-usage/

Search for package or bug name: Reporting problems