CVE-2017-15185

NameCVE-2017-15185
Descriptionplugins/ogg.c in Libmp3splt 0.9.2 calls the libvorbis vorbis_block_clear function with uninitialized data upon detection of invalid input, which allows remote attackers to cause a denial of service (application crash) via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmp3splt (PTS)jessie0.7.2-2.1vulnerable
stretch0.9.2-0.1vulnerable
mp3splt (PTS)jessie2.4.2-2fixed
buster, sid2.6.2+20170630-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmp3spltsource(unstable)(unfixed)medium
mp3spltsource(unstable)2.6.2+20170630-2medium
mp3spltsourcejessie(not affected)
mp3spltsourcewheezy(not affected)

Notes

[jessie] - mp3splt <not-affected> (Vulnerable code not present)
[wheezy] - mp3splt <not-affected> (Vulnerable code does not exist)
[stretch] - libmp3splt <no-dsa> (Minor issue)
[jessie] - libmp3splt <no-dsa> (Minor issue)
[wheezy] - libmp3splt <no-dsa> (Minor issue)
https://anonscm.debian.org/cgit/users/ron/mp3splt.git/commit/?id=18f018cd774cb931116ce06a520dc0c5f9443932

Search for package or bug name: Reporting problems