CVE-2017-16907

NameCVE-2017-16907
DescriptionIn Horde Groupware 5.2.19 and 5.2.21, there is XSS via the Color field in a Create Task List action.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1535-1, DLA-1536-1
NVD severitylow (attack range: remote)
Debian Bugs909739, 909800

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-horde (PTS)jessie5.2.1+debian0-2+deb8u3vulnerable
jessie (security)5.2.1+debian0-2+deb8u4fixed
stretch5.2.13+debian0-1vulnerable
buster, bullseye, sid5.2.20+debian0-1fixed
php-horde-core (PTS)jessie2.15.0+debian0-1+deb8u1vulnerable
jessie (security)2.15.0+debian0-1+deb8u2fixed
stretch2.27.6+debian1-2vulnerable
buster, bullseye, sid2.31.6+debian0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-hordesource(unstable)5.2.18+debian0-1low909739
php-hordesourcejessie5.2.1+debian0-2+deb8u4lowDLA-1535-1
php-horde-coresource(unstable)2.31.3+debian0-1low909800
php-horde-coresourcejessie2.15.0+debian0-1+deb8u2lowDLA-1536-1

Notes

[stretch] - php-horde <no-dsa> (Minor issue)
[stretch] - php-horde-core <no-dsa> (Minor issue)
http://code610.blogspot.com/2017/11/rce-via-xss-horde-5219.html
https://bugs.horde.org/ticket/14857
php-horde: https://github.com/horde/base/commit/fb2113bbcd04bd4a28c46aad0889fb0a3979a230
php-horde-core: https://github.com/horde/Core/commit/ecea6ea740419e19122a50579ba2903c1cb71d7a

Search for package or bug name: Reporting problems