CVE-2017-5840

NameCVE-2017-5840
DescriptionThe qtdemux_parse_samples function in gst/isomp4/qtdemux.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds heap read) via vectors involving the current stts index.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-828-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-good0.10 (PTS)wheezy0.10.31-3+nmu1vulnerable
wheezy (security)0.10.31-3+nmu1+deb7u2fixed
jessie (security), jessie0.10.31-3+nmu4+deb8u2vulnerable
gst-plugins-good1.0 (PTS)jessie (security), jessie1.4.4-2+deb8u2vulnerable
stretch, sid1.10.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-good0.10source(unstable)(unfixed)low
gst-plugins-good0.10sourcewheezy0.10.31-3+nmu1+deb7u2mediumDLA-828-1
gst-plugins-good1.0source(unstable)1.10.3-1low

Notes

http://www.openwall.com/lists/oss-security/2017/02/01/7
https://bugzilla.gnome.org/show_bug.cgi?id=777469

Search for package or bug name: Reporting problems