CVE-2017-5841

NameCVE-2017-5841
DescriptionThe gst_avi_demux_parse_ncdt function in gst/avi/gstavidemux.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds heap read) via vectors involving ncdt tags.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3820-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-good0.10 (PTS)wheezy0.10.31-3+nmu1fixed
wheezy (security)0.10.31-3+nmu1+deb7u2fixed
jessie (security), jessie0.10.31-3+nmu4+deb8u2fixed
gst-plugins-good1.0 (PTS)jessie (security), jessie1.4.4-2+deb8u3fixed
stretch1.10.4-1fixed
buster, sid1.12.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-good0.10source(unstable)(not affected)
gst-plugins-good1.0source(unstable)1.10.3-1low
gst-plugins-good1.0sourcejessie1.4.4-2+deb8u3mediumDSA-3820-1

Notes

- gst-plugins-good0.10 <not-affected> (Vulnerable code not present)
http://www.openwall.com/lists/oss-security/2017/02/01/7
https://bugzilla.gnome.org/show_bug.cgi?id=777500

Search for package or bug name: Reporting problems