CVE-2017-5842

NameCVE-2017-5842
DescriptionThe html_context_handle_element function in gst/subparse/samiparse.c in gst-plugins-base in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds write) via a crafted SMI file, as demonstrated by OneNote_Manager.smi.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3819-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-base0.10 (PTS)wheezy0.10.36-1.1fixed
wheezy (security)0.10.36-1.1+deb7u2fixed
jessie0.10.36-2fixed
gst-plugins-base1.0 (PTS)jessie (security), jessie1.4.4-2+deb8u1fixed
stretch1.10.4-1fixed
buster, sid1.12.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-base0.10source(unstable)(not affected)
gst-plugins-base1.0source(unstable)1.10.3-1medium
gst-plugins-base1.0sourcejessie1.4.4-2+deb8u1mediumDSA-3819-1

Notes

- gst-plugins-base0.10 <not-affected> (Vulnerable code not present)
http://www.openwall.com/lists/oss-security/2017/02/01/7
https://bugzilla.gnome.org/show_bug.cgi?id=777502

Search for package or bug name: Reporting problems