CVE-2017-5845

NameCVE-2017-5845
DescriptionThe gst_avi_demux_parse_ncdt function in gst/avi/gstavidemux.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via a ncdt sub-tag that "goes behind" the surrounding tag.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3820-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-good1.0 (PTS)buster1.14.4-1+deb10u1fixed
buster (security)1.14.4-1+deb10u3fixed
bullseye (security), bullseye1.18.4-2+deb11u2fixed
bookworm, bookworm (security)1.22.0-5+deb12u1fixed
sid, trixie1.22.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-good0.10source(unstable)(not affected)
gst-plugins-good1.0sourcejessie1.4.4-2+deb8u3DSA-3820-1
gst-plugins-good1.0source(unstable)1.10.3-1low

Notes

- gst-plugins-good0.10 <not-affected> (Vulnerable code not present)
https://www.openwall.com/lists/oss-security/2017/02/01/7
https://bugzilla.gnome.org/show_bug.cgi?id=777532

Search for package or bug name: Reporting problems