CVE-2017-7178

NameCVE-2017-7178
DescriptionCSRF was discovered in the web UI in Deluge before 1.3.14. The exploitation methodology involves (1) hosting a crafted plugin that executes an arbitrary program from its __init__.py file and (2) causing the victim to download, install, and enable this plugin.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-863-1, DSA-3856-1
NVD severitymedium (attack range: remote)
Debian Bugs857903

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
deluge (PTS)wheezy1.3.3-2+nmu1vulnerable
wheezy (security)1.3.3-2+nmu1+deb7u2fixed
jessie1.3.10-3vulnerable
jessie (security)1.3.10-3+deb8u1fixed
buster, sid, stretch1.3.13+git20161130.48cedf63-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
delugesource(unstable)1.3.13+git20161130.48cedf63-2medium857903
delugesourcejessie1.3.10-3+deb8u1mediumDSA-3856-1
delugesourcewheezy1.3.3-2+nmu1+deb7u1mediumDLA-863-1

Notes

http://git.deluge-torrent.org/deluge/commit/?h=1.3-stable&id=318ab179865e0707d7945edc3a13a464a108d583

Search for package or bug name: Reporting problems