CVE-2017-7485

NameCVE-2017-7485
DescriptionIn PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3, it was found that the PGREQUIRESSL environment variable was no longer enforcing a SSL/TLS connection to a PostgreSQL server. An active Man-in-the-Middle attacker could use this flaw to strip the SSL/TLS protection from a connection between a client and a server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3851-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-8.4 (PTS)wheezy8.4.22-0+deb7u1fixed
postgresql-9.1 (PTS)wheezy9.1.21-0+deb7u1fixed
wheezy (security)9.1.24-0+deb7u1fixed
jessie9.1.22-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed
postgresql-9.4 (PTS)jessie9.4.11-0+deb8u2vulnerable
jessie (security)9.4.12-0+deb8u1fixed
postgresql-9.6 (PTS)buster, sid, stretch9.6.3-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4source(unstable)(not affected)
postgresql-9.1source(unstable)(not affected)
postgresql-9.4source(unstable)(unfixed)medium
postgresql-9.4sourcejessie9.4.12-0+deb8u1mediumDSA-3851-1
postgresql-9.6source(unstable)9.6.3-1medium

Notes

- postgresql-9.1 <not-affected> (bug introduced in 9.3)
- postgresql-8.4 <not-affected> (bug introduced in 9.3)
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=aafbd1df969135c185947c596c46608fc9f4a67c

Search for package or bug name: Reporting problems