CVE-2017-7547

NameCVE-2017-7547
DescriptionPostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers to retrieve passwords from the user mappings defined by the foreign server owners without actually having the privileges to do so.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1051-1, DSA-3935-1, DSA-3936-1

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4sourcewheezy(not affected)
postgresql-8.4source(unstable)(unfixed)
postgresql-9.1sourcewheezy9.1.24lts2-0+deb7u1DLA-1051-1
postgresql-9.1sourcejessie(not affected)
postgresql-9.1source(unstable)(unfixed)
postgresql-9.4sourcejessie9.4.13-0+deb8u1DSA-3935-1
postgresql-9.4source(unstable)(unfixed)
postgresql-9.6sourcestretch9.6.4-0+deb9u1DSA-3936-1
postgresql-9.6source(unstable)9.6.4-1

Notes

[jessie] - postgresql-9.1 <not-affected> (postgresql-9.1 in jessie only provides PL/Perl)
[wheezy] - postgresql-8.4 <not-affected> (postgresql-8.4 in wheezy only provides PL/Perl)
https://www.postgresql.org/about/news/1772/

Search for package or bug name: Reporting problems