CVE-2017-7656

NameCVE-2017-7656
DescriptionIn Eclipse Jetty, versions 9.2.x and older, 9.3.x (all configurations), and 9.4.x (non-default configuration with RFC2616 compliance enabled), HTTP/0.9 is handled poorly. An HTTP/1 style request line (i.e. method space URI space version) that declares a version of HTTP/0.9 was accepted and treated as a 0.9 request. If deployed behind an intermediary that also accepted and passed through the 0.9 version (but did not act on it), then the response sent could be interpreted by the intermediary as HTTP/1 headers. This could be used to poison the cache if the server allowed the origin client to generate arbitrary content in the response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs902953

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jetty (PTS)jessie6.1.26-4vulnerable
jetty8 (PTS)jessie8.1.16-4vulnerable
jetty9 (PTS)stretch9.2.21-1vulnerable
buster, sid9.2.25-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jettysource(unstable)(unfixed)
jetty8source(unstable)(unfixed)
jetty9source(unstable)9.2.25-1low902953

Notes

https://bugs.eclipse.org/bugs/show_bug.cgi?id=535667
https://github.com/eclipse/jetty.project/commit/a285deea

Search for package or bug name: Reporting problems