CVE-2017-7658

NameCVE-2017-7658
DescriptionIn Eclipse Jetty Server, versions 9.2.x and older, 9.3.x (all non HTTP/1.x configurations), and 9.4.x (all HTTP/1.x configurations), when presented with two content-lengths headers, Jetty ignored the second. When presented with a content-length and a chunked encoding header, the content-length was ignored (as per RFC 2616). If an intermediary decided on the shorter length, but still passed on the longer body, then body content could be interpreted by Jetty as a pipelined request. If the intermediary was imposing authorization, the fake pipelined request would bypass that authorization.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4278-1
NVD severityhigh (attack range: remote)
Debian Bugs902953

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jetty (PTS)jessie6.1.26-4vulnerable
jetty8 (PTS)jessie8.1.16-4vulnerable
jetty9 (PTS)stretch9.2.21-1vulnerable
stretch (security)9.2.21-1+deb9u1fixed
buster, sid9.2.26-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jettysource(unstable)(unfixed)high
jetty8source(unstable)(unfixed)high
jetty9source(unstable)9.2.25-1low902953
jetty9sourcestretch9.2.21-1+deb9u1highDSA-4278-1

Notes

[jessie] - jetty <ignored> (very hard to exploit, complex patch)
[jessie] - jetty8 <ignored> (very hard to exploit, complex patch)
https://bugs.eclipse.org/bugs/show_bug.cgi?id=535669
https://github.com/eclipse/jetty.project/commit/a285deea
Exploit very unlikely, needs a very particular intermediary behaviour.

Search for package or bug name: Reporting problems