CVE-2017-7890

NameCVE-2017-7890
DescriptionThe GIF decoding function gdImageCreateFromGifCtx in gd_gif_in.c in the GD Graphics Library (aka libgd), as used in PHP before 5.6.31 and 7.x before 7.1.7, does not zero colorMap arrays before use. A specially crafted GIF image could use the uninitialized tables to read ~700 bytes from the top of the stack, potentially disclosing sensitive information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1055-1, DSA-3938-1
NVD severitymedium (attack range: remote)
Debian Bugs869263

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2vulnerable
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9vulnerable
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-4fixed
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11vulnerable
jessie (security), jessie5.6.30+dfsg-0+deb8u1vulnerable
php7.0 (PTS)stretch7.0.19-1vulnerable
buster, sid7.0.25-1fixed
php7.1 (PTS)buster, sid7.1.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.5-1medium869263
libgd2sourcejessie2.1.0-5+deb8u10mediumDSA-3938-1
libgd2sourcestretch2.2.4-2+deb9u1mediumDSA-3938-1
libgd2sourcewheezy2.0.36~rc1~dfsg-6.1+deb7u9mediumDLA-1055-1
php5source(unstable)(unfixed)unimportant
php7.0source(unstable)7.0.22-1unimportant
php7.1source(unstable)7.1.8-1unimportant

Notes

PHP Bug: https://bugs.php.net/bug.php?id=74435
Fixed in 7.1.7, 7.0.21, 5.6.31
https://github.com/libgd/libgd/issues/399
https://github.com/libgd/libgd/commit/c613bc169802bb4b639ee2e15c61b25b80a88424

Search for package or bug name: Reporting problems