CVE-2017-9031

NameCVE-2017-9031
DescriptionThe WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-943-1, DSA-3856-1
NVD severityhigh (attack range: remote)
Debian Bugs862611

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
deluge (PTS)wheezy1.3.3-2+nmu1vulnerable
wheezy (security)1.3.3-2+nmu1+deb7u2fixed
jessie (security), jessie1.3.10-3+deb8u1fixed
stretch1.3.13+git20161130.48cedf63-3fixed
sid1.3.15-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
delugesource(unstable)1.3.13+git20161130.48cedf63-3high862611
delugesourcejessie1.3.10-3+deb8u1highDSA-3856-1
delugesourcewheezy1.3.3-2+nmu1+deb7u2highDLA-943-1

Notes

http://dev.deluge-torrent.org/wiki/ReleaseNotes/1.3.15
Fixed by: http://git.deluge-torrent.org/deluge/commit/?h=1.3-stable&id=41acade01ae88f7b7bbdba308a0886771aa582fd

Search for package or bug name: Reporting problems