CVE-2017-9525

NameCVE-2017-9525
DescriptionIn the cron package through 3.0pl1-128 on Debian, and through 3.0pl1-128ubuntu2 on Ubuntu, the postinst maintainer script allows for group-crontab-to-root privilege escalation via symlink attacks against unsafe usage of the chown and chmod programs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1723-1
NVD severitymedium
Debian Bugs864466, 993731

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cron (PTS)stretch3.0pl1-128+deb9u1vulnerable
buster3.0pl1-134+deb10u1fixed
bookworm, sid, bullseye3.0pl1-137fixed
systemd-cron (PTS)stretch1.5.8-1vulnerable
buster1.5.14-2vulnerable
bullseye1.5.16-1vulnerable
bookworm, sid1.5.17-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cronsourcejessie3.0pl1-127+deb8u2DLA-1723-1
cronsource(unstable)3.0pl1-129864466
systemd-cronsource(unstable)1.5.17-2993731

Notes

[stretch] - cron <no-dsa> (Minor issue)
[wheezy] - cron <no-dsa> (Minor issue)
[bullseye] - systemd-cron <no-dsa> (Minor issue)
[buster] - systemd-cron <no-dsa> (Minor issue)
[stretch] - systemd-cron <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2017/06/08/3

Search for package or bug name: Reporting problems