CVE-2017-9774

NameCVE-2017-9774
DescriptionRemote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. Exploitation requires authentication.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1395-1, DSA-4276-1
NVD severitymedium (attack range: remote)
Debian Bugs865505

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-horde-image (PTS)jessie2.1.0-4vulnerable
jessie (security)2.1.0-4+deb8u1fixed
stretch2.3.6-1vulnerable
stretch (security)2.3.6-1+deb9u1fixed
buster, sid2.5.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-horde-imagesource(unstable)2.5.1-1medium865505
php-horde-imagesourcejessie2.1.0-4+deb8u1mediumDLA-1395-1
php-horde-imagesourcestretch2.3.6-1+deb9u1mediumDSA-4276-1

Notes

https://lists.horde.org/archives/announce/2017/001234.html
https://github.com/horde/horde/commit/01a11ccd37149101d67e0b20261fa48ab07dae13
Regression in upstream patch, fixing in https://github.com/horde/Image/pull/1

Search for package or bug name: Reporting problems