CVE-2018-1000074

NameCVE-2018-1000074
DescriptionRubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1352-1, DSA-4219-1
NVD severitymedium (attack range: remote)
Debian Bugs895778

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jruby (PTS)jessie1.5.6-9vulnerable
stretch1.7.26-1vulnerable
stretch (security)1.7.26-1+deb9u1fixed
buster, sid9.1.13.0-1vulnerable
ruby2.1 (PTS)jessie2.1.5-2+deb8u3vulnerable
jessie (security)2.1.5-2+deb8u1vulnerable
ruby2.3 (PTS)stretch (security), stretch2.3.3-1+deb9u2vulnerable
ruby2.5 (PTS)buster, sid2.5.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jrubysource(unstable)(unfixed)medium895778
jrubysourcejessie(unfixed)end-of-life
jrubysourcestretch1.7.26-1+deb9u1mediumDSA-4219-1
jrubysourcewheezy1.5.6-5+deb7u2mediumDLA-1352-1
ruby1.9.1source(unstable)(unfixed)medium
ruby2.1source(unstable)(unfixed)medium
ruby2.3source(unstable)(unfixed)medium
ruby2.5source(unstable)2.5.0-5medium
rubygemssource(unstable)(unfixed)medium

Notes

[wheezy] - ruby1.9.1 <no-dsa> (Minor issue, too intrusive to backport)
[wheezy] - rubygems <no-dsa> (Minor issue)
[jessie] - jruby <end-of-life> (See DSA-4219-1)
https://github.com/rubygems/rubygems/commit/254e3d0ee873c008c0b74e8b8abcbdab4caa0a6d
https://www.ruby-lang.org/en/news/2018/02/17/multiple-vulnerabilities-in-rubygems/

Search for package or bug name: Reporting problems