CVE-2018-1000078

NameCVE-2018-1000078
DescriptionRubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1336-1, DLA-1337-1, DLA-1358-1, DLA-1421-1, DSA-4219-1, DSA-4259-1
NVD severitymedium (attack range: remote)
Debian Bugs895778

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jruby (PTS)jessie1.5.6-9vulnerable
stretch (security), stretch1.7.26-1+deb9u1fixed
buster, sid9.1.13.0-1vulnerable
ruby2.1 (PTS)jessie2.1.5-2+deb8u3vulnerable
jessie (security)2.1.5-2+deb8u6fixed
ruby2.3 (PTS)stretch2.3.3-1+deb9u2vulnerable
stretch (security)2.3.3-1+deb9u4fixed
ruby2.5 (PTS)buster, sid2.5.3-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jrubysource(unstable)(unfixed)medium895778
jrubysourcejessie(unfixed)end-of-life
jrubysourcestretch1.7.26-1+deb9u1mediumDSA-4219-1
jrubysourcewheezy1.5.6-5+deb7u1mediumDLA-1337-1
ruby1.9.1source(unstable)(unfixed)medium
ruby1.9.1sourcewheezy1.9.3.194-8.1+deb7u8mediumDLA-1358-1
ruby2.1source(unstable)(unfixed)medium
ruby2.1sourcejessie2.1.5-2+deb8u4mediumDLA-1421-1
ruby2.3source(unstable)(unfixed)medium
ruby2.3sourcestretch2.3.3-1+deb9u3mediumDSA-4259-1
ruby2.5source(unstable)2.5.0-5medium
rubygemssource(unstable)(unfixed)medium
rubygemssourcewheezy1.8.24-1+deb7u2mediumDLA-1336-1

Notes

[jessie] - jruby <end-of-life> (See DSA-4219-1)
https://github.com/rubygems/rubygems/commit/66a28b9275551384fdab45f3591a82d6b59952cb
https://www.ruby-lang.org/en/news/2018/02/17/multiple-vulnerabilities-in-rubygems/

Search for package or bug name: Reporting problems