CVE-2018-1000140

NameCVE-2018-1000140
Descriptionrsyslog librelp version 1.2.14 and earlier contains a Buffer Overflow vulnerability in the checking of x509 certificates from a peer that can result in Remote code execution. This attack appear to be exploitable a remote attacker that can connect to rsyslog and trigger a stack buffer overflow by sending a specially crafted x509 certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4151-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
librelp (PTS)jessie (security), jessie1.2.7-2+deb8u1fixed
stretch (security), stretch1.2.12-1+deb9u1fixed
buster1.2.18-1fixed
sid1.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librelpsource(unstable)1.2.15-1high
librelpsourcejessie1.2.7-2+deb8u1highDSA-4151-1
librelpsourcestretch1.2.12-1+deb9u1highDSA-4151-1
librelpsourcewheezy(not affected)

Notes

[wheezy] - librelp <not-affected> (vulnerable code not present)
https://www.rsyslog.com/cve-2018-1000140/
Fixed by: https://github.com/rsyslog/librelp/commit/2cfe657672636aa5d7d2a14cfcb0a6ab9d1f00cf

Search for package or bug name: Reporting problems