CVE-2018-1002200

NameCVE-2018-1002200
Descriptionplexus-archiver before 3.6.0 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in an archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4227-1
NVD severitymedium (attack range: remote)
Debian Bugs900953

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
plexus-archiver (PTS)jessie (security), jessie1.2-1+deb8u1fixed
stretch (security), stretch2.2-1+deb9u1fixed
buster, sid3.6.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
plexus-archiversource(unstable)3.6.0-1medium900953
plexus-archiversourcejessie1.2-1+deb8u1mediumDSA-4227-1
plexus-archiversourcestretch2.2-1+deb9u1mediumDSA-4227-1

Notes

https://github.com/codehaus-plexus/plexus-archiver/pull/87
https://github.com/codehaus-plexus/plexus-archiver/commit/58bc24e465c0842981692adbf6d75680298989de

Search for package or bug name: Reporting problems