CVE-2018-10120

NameCVE-2018-10120
DescriptionThe SwCTBWrapper::Read function in sw/source/filter/ww8/ww8toolbar.cxx in LibreOffice before 5.4.6.1 and 6.x before 6.0.2.1 does not validate a customizations index, which allows remote attackers to cause a denial of service (heap-based buffer overflow with write access) or possibly have unspecified other impact via a crafted document that contains a certain Microsoft Word record.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1356-1, DSA-4178-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)stretch (security), stretch1:5.2.7-1+deb9u11fixed
buster1:6.1.5-3+deb10u6fixed
buster (security)1:6.1.5-3+deb10u4fixed
bullseye, sid1:7.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesourcewheezy1:3.5.4+dfsg2-0+deb7u11DLA-1356-1
libreofficesourcejessie1:4.3.3-2+deb8u11DSA-4178-1
libreofficesourcestretch1:5.2.7-1+deb9u4DSA-4178-1
libreofficesource(unstable)1:6.0.2-1

Notes

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=6173
https://gerrit.libreoffice.org/#/c/49486/
https://gerrit.libreoffice.org/#/c/49499/
https://gerrit.libreoffice.org/#/c/49500/
https://gerrit.libreoffice.org/gitweb?p=core.git;a=commit;h=017fcc2fcd00af17a97bd5463d89662404f57667
https://www.libreoffice.org/about-us/security/advisories/cve-2018-10120/

Search for package or bug name: Reporting problems