CVE-2018-1115

NameCVE-2018-1115
Descriptionpostgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is added to a database, an attacker able to connect to it could exploit this to force log rotation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-9.1 (PTS)jessie9.1.22-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed
postgresql-9.4 (PTS)jessie9.4.18-0+deb8u1fixed
jessie (security)9.4.19-0+deb8u1fixed
postgresql-9.6 (PTS)stretch (security), stretch9.6.10-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-10source(unstable)10.4-1medium
postgresql-9.1source(unstable)(unfixed)medium
postgresql-9.1sourcejessie(not affected)
postgresql-9.1sourcewheezy(not affected)
postgresql-9.4source(unstable)(unfixed)medium
postgresql-9.4sourcejessie(not affected)
postgresql-9.6source(unstable)(unfixed)medium
postgresql-9.6sourcestretch9.6.9-0+deb9u1medium

Notes

[jessie] - postgresql-9.4 <not-affected> (Code not present)
[jessie] - postgresql-9.1 <not-affected> (Code not present)
[wheezy] - postgresql-9.1 <not-affected> (Code not present)

Search for package or bug name: Reporting problems