CVE-2018-11319

NameCVE-2018-11319
DescriptionSyntastic (aka vim-syntastic) through 3.9.0 does not properly handle searches for configuration files (it searches the current directory up to potentially the root). This improper handling might be exploited for arbitrary code execution via a malicious gcc plugin, if an attacker has write access to a directory that is a parent of the base directory of the project being checked. NOTE: exploitation is more difficult after 3.8.0 because filename prediction may be needed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1444-1, DSA-4261-1
NVD severityhigh (attack range: remote)
Debian Bugs894736

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim-syntastic (PTS)jessie3.5.0-1vulnerable
jessie (security)3.5.0-1+deb8u1fixed
stretch3.7.0-1vulnerable
stretch (security)3.7.0-1+deb9u2fixed
buster, sid3.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vim-syntasticsource(unstable)3.9.0-1high894736
vim-syntasticsourcejessie3.5.0-1+deb8u1highDLA-1444-1
vim-syntasticsourcestretch3.7.0-1+deb9u2highDSA-4261-1

Notes

https://github.com/vim-syntastic/syntastic/issues/2170
https://github.com/vim-syntastic/syntastic/commit/6d7c0b394e001233dd09ec473fbea2002c72632f

Search for package or bug name: Reporting problems