CVE-2018-12565

NameCVE-2018-12565
DescriptionAn issue was discovered in Linaro LAVA before 2018.5.post1. Because of use of yaml.load() instead of yaml.safe_load() when parsing user data, remote code execution can occur.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4234-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lava (PTS)buster, sid2018.11-1fixed
lava-server (PTS)jessie2014.09.1-1fixed
jessie (security)2014.09.1-1+deb8u1fixed
stretch (security), stretch2016.12-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lavasource(unstable)2018.5.post1-1medium
lava-serversource(unstable)(unfixed)medium
lava-serversourcejessie(not affected)
lava-serversourcestretch2016.12-3mediumDSA-4234-1

Notes

[jessie] - lava-server <not-affected> (vulnerable code not present)
https://git.linaro.org/lava/lava.git/commit/?id=583666c84ea2f12797a3eb71392bcb05782f5b14

Search for package or bug name: Reporting problems